Hive AdKit은 Hive SDK와 개별모듈 유저가 AD(X)에서 제공하는 Unity 패키지를 적용하는 과정에 발생하는 오류를 수정하고, 사용의 편의를 돕기 위해 제작된 광고모듈입니다. Hive AdKit을 지원하는 버전과 적용 방법을 아래에서 차근차근 살펴보세요.

최신 다운로드

배포일 다운로드
2024-01-15 HiveAdKit_v1.4.5_for_Unity_ADX.zip

개발 환경

  • 최소 지원 버전
    • Hive SDK v4.14.4.0
    • Hive SDK v4.14.4.0 KS
    • Hive SDK v1.18.3.0
    • 개별모듈 Peppermint Android v2.9.2
    • 개별모듈 Peppermint iOS v2.8.4

Unity와 Cocos2D-X 환경을 지원합니다.

릴리즈 노트

V1.4.5 (2024-01-15)

  • ADX-Unity 2.5.2 버전으로 업데이트합니다.
    • ADXLibrary-Android 2.5.1 버전을 사용하도록 변경합니다.
    • ADXLibrary-iOS 2.5.2 버전을 사용하도록 변경합니다.
    • Google UMP를 사용하여 GDPR 동의 팝업을 제공합니다. InitializeWithShowADXConsent API에 테스트 디바이스를 설정하면 GDPR 동의 팝업 노출 테스트를 진행할 수 있습니다.

V1.4.4 (2023-10-31)

  • ADX-Unity 2.4.1 버전으로 업데이트합니다.
    • ADXLibrary-Android 2.4.0 버전을 사용하도록 변경합니다.
    • ADXLibrary-iOS 2.4.0.3 버전을 사용하도록 변경합니다.
  • Hive SDK에서 서드파티 어트리뷰션(AppsFlyer, Singular, Firebase Analytics)을 사용할 때 RewardedAd 또는 Interstitial 광고 수익이 발생하면 광고 수익 정보를 서드파티 어트리뷰션으로 자동 전송합니다. Adjust로도 자동 전송을 지원하지만, 먼저 Adjust에 별도로 관련 기능 지원을 확인해야 합니다.
  • Gradle & Gradle Plug-in 버전 설정 안내를 가이드에 추가했습니다.

V1.4.3 (2023-08-10)

  • ADX-Unity 2.3.5 버전으로 업데이트합니다.
    • ADXLibrary-Android 2.3.10 버전을 사용하도록 변경합니다.
    • ADXLibrary-iOS 2.3.7 버전을 사용하도록 변경합니다.
  • OnPaidEvent로 수신하는 eCPM값이 과소 측정되는 이슈를 수정했습니다.

V1.4.2 (2023-06-20)

  • ADX-Unity 2.3.4 버전으로 업데이트합니다.
    • ADXLibrary-Android 2.3.8 버전을 사용하도록 변경합니다.
    • ADXLibrary-iOS 2.3.5 버전을 사용하도록 변경합니다.
  • OnPaidEvent를 수신합니다. OnPaidEvent 이벤트를 통해 광고 노출이 발생동안 예상되는 eCPM 측정치를 받아볼 수 있습니다. Rewarded Video, Interstitial에서 노출당 광고 추정 수익을 측정할 수 있습니다.

V1.4.1 (Mar 20, 2023)

  • ADX-Unity 2.3.2 버전으로 업데이트합니다.

    • ADXLibrary-Android 2.3.3 버전을 사용하도록 변경합니다.
    • ADXLibrary-iOS 2.3.2 버전을 사용하도록 변경합니다.

V1.4.0 (Feb 20, 2023)

  • iOS – Xcode 14 이상에서 빌드가 가능합니다.
  • ADX-Unity 2.3.0 버전으로 업데이트합니다.

  • SKAdNetwork ID가 갱신되었습니다.
  • EDM4U 1.2.175 버전을 제공합니다.

V1.3.3 (Aug 22, 2022)

  • ADX-Unity 2.2.6 버전으로 업데이트
    • ADXLibrary-iOS 2.2.6 버전 사용 지원
    • ADXLibrary-Android 2.2.6 버전 사용 지원
    • 1초 이내 광고 생성을 연속으로 하는 경우 발생할 수 있는 크래시 수정
  • EDM4U 1.2.171 버전 제공

V1.3.2 (May 25, 2022)

  • ADX-Unity 2.1.7 버전으로 업데이트
    • ADXLibrary-iOS 2.1.8 버전 사용 지원

V1.3.1 (May 19, 2022)

  • ADX-Unity 2.1.6 버전으로 업데이트
    • ADXLibrary-Android 2.1.6 버전 사용 지원

V1.3.0 (May 17, 2022)

  • 로그 전송 시 개별 추가 정보를 포함하는 기능 추가
  • ADX-Unity 2.1.5 버전으로 업데이트
  • SKAdNetwork ID 갱신

적용 및 포함된 라이브러리 (Hive AdKit v1.4.5 기준)

  • ADXLibrary

    • ADXLibrary-Unity 2.5.1
    • ADXLibrary-Android 2.5.1

      • ADXLibrary-Android-rewarded-video 2.5.1
      • ADXLibrary-Android-adx-library-standard 2.5.1
      • ADXLibrary-Android-adx-library-base 2.5.1
    • ADXLibrary-iOS 2.5.2

      • ADXLibrary-iOS/UnityPlugin 2.5.2
    • ADXLibrary-iOS-FBAudienceNetwork 2.5.2
    • ADXLibrary-iOS-UnityAds 2.5.2
    • ADXLibrary-iOS-Pangle 2.5.2
    • ADXLibrary-iOS-Fyber 2.5.2
    • ADXLibrary-iOS-Mintegral 2.5.2
  • AdMob-Unity 8.6.0

    • AdMob-Android 22.5.0
    • AdMob-iOS 10.13.0
  • Meta-Android 6.16.0
  • Meta-iOS 6.14.0
  • UnityAds-Android 4.9.1
  • UnityAds-iOS 4.9.2
  • Cauly-Android 3.5.26
  • Cauly-iOS 3.1.21
  • AdPieSDK-Android 1.13.1
  • AdPieSDK-iOS 1.5.7
  • AdFit-Android 3.13.6
  • AppLovin-Android 12.0.0
  • AppLovin-iOS 12.0.0
  • Fyber-Android 8.2.4
  • Fyber-iOS 8.2.5
  • Pangle-Android 5.4.1.1
  • Pangle-iOS 5.5.0.5
  • Mintegral-Android 16.5.41
  • Mintegral-iOS 7.5.1
  • Tnk SDK-Android 7.21.7
  • Tnk SDK-iOS 1.13.0